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Introduction 
Allstream’s Auto Attendant is an automated receptionist service. When turned on, it answers your calls 
automatically, and offers your callers a list of options that you define. You can allow your callers to listen to 
messages (such as your opening times), to leave a message, or to be transferred to a real person, and you can 
configure the menu options for all hours or for both business and non-business hours. 

Allstream offers two versions of the Auto Attendant feature: Premium Attendant and Easy Attendant: 

Premium Attendant (PA) is a feature that provides an automatic call answering service that delivers an interactive 
menu to callers. Its main features include: 

• Multi-level menus 
• Transfer to voicemail by name or number 
• Intercept mailbox 
• Configurable error behavior 
• Advanced scheduling 
• Recording upload 

Easy Attendant (EA) is a feature that provides an automatic call answering service. It delivers an interactive menu 
to callers, including playing an initial greeting and other recorded announcements. It can make use of a schedule 
to provide different menus at different times of day. For more information, see the Voicemail Easy Attendant 
Quick Start Guide. 

Setting Up the Premium Attendant 
To set up the Premium Attendant: 

1. Using a web browser, visit https://myvoice.allstream.com. 
2. Enter your subscriber number, which is your 10-digit mailbox number. 
3. Enter your password.  
4. Click Login. 

The Main tab displays. 

https://myvoice.allstream.com/
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Main Tab 

5. Configure your attendant menu settings. These settings display on the right side of the Main tab or are 
accessible by using the individual tabs at the top of the page. For details about these settings, see the 
following sections: 
 

• Setting a Schedule, page 3 
• Managing Your Attendant Menus, page 6 
• Working with Announcements, page 9 
• Configuring Extensions, page 11 
• Advanced Settings, page 14 

 
6. From the Main tab, click Turn ON. 

Note: When the attendant is turned off, your callers are told that your number is unreachable. 
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Setting a Schedule 
A schedule allows you to define when a specific menu is played to callers based on the time of day or day of the 
week. You can configure a schedule by modifying a sample or using a blank schedule. Once a schedule has been 
applied, it is displayed on the Schedule tab. 

Note: Once a schedule is applied, it may be modified but not removed. 

To configure a schedule for your attendant menus: 

1. Click the weekly schedule and holidays link on the Main tab or click the Schedule tab at the top of the 
page.  
The Schedule tab displays.  

 

Schedule Tab 

2. Choose the method by which you want to create a schedule: An example schedule that you can 
customize or A blank schedule. 
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Schedule Tab, Sample Schedule 

Defining Time Periods 

Time periods allow you to set specific attendant menus based on the time of day. For example, you can set a 
specific menu to play for callers during working hours and another menu to play during lunch. 

While the sample schedule provides a set of pre-defined time periods that may be modified or deleted, you can 
create new time periods for either the sample schedule or the blank schedule. 

Creating a Time Period 
To create a new time period: 

1. At the top of the Schedule tab, click Add New Time Period. 
A dialog box displays. 

3. Click Apply to save your changes. 
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Specifying a Menu for a Time Period 
To specify a menu for a time period: 

1. Select the desired time period from the list. 
2. From the During this period, use this menu list, select a menu to apply or create a new menu. 

If you are creating a new menu, enter a menu name and description in the dialog box and click OK. 
3. Click Apply to save your changes. 

Note: If you created a new menu on the Schedule tab, make sure to configure your new menu settings. For more 
information, see Managing Your Attendant Menus, page 6. 

Ranaming a Time Period 
To rename a time period: 

1. Select the desired time period from the list. 
2. Click Rename. 

A dialog box displays. 
3. Enter a new name for the time period and click OK. 

The renamed time period displays in the list. 
4. Click Apply to save your changes. 

Applying a Time Period to the Schedule 
To apply a time period to the schedule: 

1. Select the desired time period from the list. 
2. Select the days and times on the schedule where you want to apply the time period. You can also click 

and drag to select adjacent days and times. 
3. To undo a time period on the schedule, select the days and times you want to undo. 
4. Click Apply to save your changes. 

Deleting a Time Period 
To delete a time period: 

1. Select the desired time period from the list. 
2. Click Delete. 

A confirmation dialog box displays. 
3. Click OK to delete the time period. 
4. Click Apply to save your changes. 
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Managing Your Attendant Menus 
Attendant menus are played for your callers during specific time periods on a schedule. Once your menus are 
created and configured, you can apply them to a time period using the Schedule tab. For more information, see 
Specifying a Menu for a Time Period, page 5. 

To manage your attendant menus, click the menus link on the Main tab or click the Menus tab at the top of the 
page.  

 

Menus Tab 

Creating or Modifying a Menu 

To create a menu, at the top of the Menus tab, click Add New Menu.  

To modify a menu, select the menu you want to modify from the Menus list. 

Settings for the new menu display on the page: General, Keys, Timeout, and References. 
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Menu Settings, General 

General Settings 
General settings include the menu name, description, and announcement. 

1. Enter a name and description for the menu.  
2. From the Menu Announcement drop-down list, select an announcement or create a new announcement. 

If you are creating a new announcement, enter an announcement name and description in the dialog box 
and click OK. 

3. Click Apply to save your changes. 

Menu Defined Keys Settings 
Menu defined keys settings allow you to define the action taken when a caller presses a number on their 
telephone keypad.  

Note: Keys settings defined here apply only to the selected menu. The Use Default selection applies the default 
setting to the key as defined using the Advanced tab. For more information, see Default Keys Settings, page 14. 

 

Menu Settings, Keys 
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2. Assign an action to each key as needed. Some actions require additional information, such as extensions 
or announcements. For more information, see Working with Announcements, page 9 and Configuring 
Extensions, page 11. 

3. Click Apply to save your changes. 

Timeout Settings 
Timeout settings allow you to override and change the default timeout behavior. 

1. Click Timeout at the top of the menu settings. 
The Timeout settings display. 

 

Menu Settings, Timeout 

2. To override the default timeout settings, check the Override timeout behavior checkbox. 
3. Select the new timeout duration. 
4. Select the action to perform after a timeout. 
5. Click Apply to save your changes. 

To revert timeout settings back to default, uncheck the Override timeout behavior checkbox. 

References 
The References tab displays which menus and time periods make reference to the currently selected menu. This 
feature is useful if you want to delete a menu, as you can only do this if the menu is not referenced by any menus 
or time periods. 
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Working with Announcements 
Announcements are the messages that your callers hear before the menu options are presented during a time 
period. Announcements are required for each menu configuration. The Announcements tab lists all existing 
announcements (up to 300). The Search field at the top of the Announcements tab allows you to quickly locate 
an announcement by typing in all or part of the name, description, or a recording ID number. 

Note: The announcements list contains only those for which the recording can be changed. System 
announcements such as the announcement played when the user presses an invalid key, cannot be changed or 
listened to via the web interface. 

To start working with your announcements, click the announcements link on the Main tab, or click the 
Announcements tab. 

 

Announcements Tab 

The icons on the left indicate the status of each announcement: 

        A recording exists for this announcement. Click the icon to play the announcement 

        A recording does not exist for this announcement. 
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The icons on the right indicate the state of each announcement: 

        The announcement is referenced by one or more menus 

        The announcement is not referenced by a menu 

        The announcement is referenced by a menu but does not have a recording 

Downloading a Recording Report 

A recording report is generated in CSV file format. This report provides a list of all announcements and includes 
the number, name, and description of each announcement, as well as whether audio is present and whether it is 
referenced by an existing menu. 

To download a recording report: 

1. Click Download recording report….  
A confirmation dialog box displays. 

2. Click OK. 
Once the report is generated, select the location where you want to save the file and name the file. 

3. Click Save.  

Note: For large numbers of announcements, this process may take several minutes. 

Creating an Announcement 

To create an announcement: 

1. From the Announcements tab, click Add New Announcement. 
The Add Announcement dialog box displays. 

 

Add Announcement Dialog Box 

2. Enter a name and description for the announcement. 
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3. From the drop-down list, select the method by which to create the announcement: 
 
• Record / Play Announcement: Use your computer sound card and microphone to record your 

message. 
• Upload Announcement: Browse for and upload a pre-recorded audio file of your message. 
• Record by Phone: Record your message using your telephone. 

a. Dial your attendant access number from your telephone. 
b. Follow the prompts to edit announcements. 
c. When prompted, enter the announcement number as displayed on the Add Announcement 

dialog box. 

Note: To offer your callers the option to listen to announcements in your attendant menu, use the web 
interface to assign the appropriate keys to Play announcement before turning on your attendant. For more 
information about assigning keys, see Menu Defined Keys Settings, page 7 and Default Keys Settings, page 
14. 

Modifying an Announcement 

To modify an announcement: 

1. Click the announcement number or name from the list on the Announcements tab. 
The Announcement dialog box displays. 

2. Make changes as needed and click Save. 

Downloading a Recorded Announcement 

To download a recorded announcement: 

1. Click the announcement number or name from the list on the Announcements tab. 
The Announcement dialog box displays. 

2. Click Download Announcement. 
3. Select the location where you want to save the file and name the file as needed. 
4. Click Save.  

Deleting Announcements 

To delete one or more announcements: 

1. From the Announcements tab, check the box next to each announcement you want to delete. 
2. Click Delete. 

A confirmation dialog box displays. 
3. Click OK. 

Configuring Extensions 
In order to offer your callers a "Dial by..." key option, you must define the set of extensions they can dial. For each 
extension, you must specify the extension number (a short number of your choice, such as 107), the extension's 
name, and the phone number where your caller should be transferred to if they dial this extension.  
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To manage your extensions, click the extensions link on the Main tab or click the Extensions tab at the top of 
the page. There are two types of extensions available on the Extensions tab: Business Group Extensions and 
Additional Extensions. 

 

Extensions Tab 

Business Group Extensions 

Business Group Extensions are defined in a business group and automatically listed in the Business Group 
Extensions area of the Extensions tab. Extensions that are added to a business group later are automatically 
included and made available for use with “Dial by…” or “Voicemail by…” key options.  

Note: Extensions without spoken names will not be made available for Dial by Name or Voicemail by Name key 
options. 

To include one or more extensions for use with the “Dial by…” or “Voicemail by…” key options, check the box 
next to each extension and click Include Selected. A checkmark displays in the Included? column for each 
included extension. 

To exclude one or more extensions, check the box next to each extension and click Excluded Selected. The 
Included? column for each excluded extension is left blank. 

Additional Extensions 

Additional Extensions are extensions outside of a business group that are manually defined for use with the “Dial 
by…” or “Voicemail by…” key options. To get started, click Additional Extensions on the Extensions tab. 
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Adding an Extension 
To add an extension: 

1. From the Additional Extensions area of the Extensions tab, click Add Extension. 
The Edit Extension dialog box displays. 

2. Use the arrows next to each section of the dialog box to expand/collapse required elements. 
3. In the Name and Number section, specify the extension number (a short number of your choice, such as 

107), the extension's name, and the phone number where your caller should be transferred to if they dial 
this extension. 

4. Provide a recorded name or uploaded recording of a spoken name. This is played to callers if they enter a 
name that is not unique to allow them to refine their search. For example, if there are two extensions 
called "John" and the caller enters "John", they hear the full names of both the extensions and can 
choose between them. Extensions that do not have a spoken name recorded cannot be reached by “dial 
by name" options.  

To record, click Record Spoken Name. 

• To start recording, click the Record icon . 
• To stop recording, click the Stop icon .  
• To listen, click the Play icon .   

To upload a recording, click Upload Spoken 
Name, browse for and select your file, and click 
Upload. 

Note: Extensions without spoken names will not 
be made available for Dial by Name or Voicemail 
by Name key options. 

5. When finished, click Save. 

Modifying an Extension 
To modify an extension: 

1. From the Additional Extensions area of the Extensions tab, click the extension in the list you want to 
modify. 
The Edit Extension dialog box displays. 

2. Make changes as needed and click Save. 

Deleting Extensions 
To delete one or more extensions: 

3. Click OK. 
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Advanced Settings 
Advanced settings allow you to define the default keys settings for all attendant menus, error handling methods, 
extension matching, and intercept mailbox. 

To manage your advanced settings, click the advanced link on the Main tab or click the Advanced tab at the top 
of the page. There are three types of advanced settings available on the Advanced tab: Default keys, Error 
Handling, and Other settings. 

 

Advanced Tab 

Default Keys Settings 

Advanced default keys settings allow you to define the actions that are applied whenever you select Use Default 
for a key setting during menu configuration. For more information about key settings in a menu configuration, see 
Menu Defined Keys Settings, page 7. 

To configure your default keys settings: 

1. Click the advanced link on the Main tab or click the Advanced tab. 
The Keys settings display. 
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Advanced Tab, Default Keys 

2. Assign an action to each key as needed. Some actions require additional information, such as extensions 
or announcements. For more information, see Working with Announcements, page 9 and Configuring 
Extensions, page 11. 

3. Click Apply to save your changes. 

Error Handling 

You can change the following global settings that determine what happens when there is an error when your 
callers are using the attendant. To get started, click Error handling on the Advanced tab. 

 

Advanced Tab, Error Handling 
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Make your selections as needed and click Apply to save your changes. 

• Timeout: This defines the behavior of the attendant if a caller fails to press a key within the specified time 
(in seconds). 

• Unknown input: This defines the behavior of the attendant if a caller presses a key that has not been 
assigned an action. 

• Call Transfer: This defines the behavior of the attendant if a call transfer connection fails. 
• Invalid Extensions: This determines the behavior of the attendant if a caller presses an unrecognized 

extension number. 

Note: If a selected event is incorrectly configured, an error icon displays. 

Other Settings 

Other advanced settings include extension matching preferences and a default intercept mailbox. To get started, 
click Other settings on the Advanced tab. 

 

Advanced Tab, Other Settings 

Make your selections as needed and click Apply to save your changes: 

• Select the method by which to match extensions when a caller dials the name of the extension or mailbox 
to which they want to transfer. 

• Provide the voicemail number where callers will be sent when the Intercept Mailbox key action is applied 
to a menu. This applies to both menu defined and advanced key settings. For more information about key 
settings, see Menu Defined Keys Settings, page 7 and Default Keys Settings, page 14. 


	Premium Attendant User Guide
	Copyright
	Contents
	Introduction
	Setting Up the Premium Attendant
	Setting a Schedule
	Defining Time Periods
	Creating a Time Period
	Specifying a Menu for a Time Period
	Ranaming a Time Period
	Applying a Time Period to the Schedule
	Deleting a Time Period


	Managing Your Attendant Menus
	Creating or Modifying a Menu
	General Settings
	Menu Defined Keys Settings
	Timeout Settings
	References


	Working with Announcements
	Downloading a Recording Report
	Creating an Announcement
	Modifying an Announcement
	Downloading a Recorded Announcement
	Deleting Announcements

	Configuring Extensions
	Business Group Extensions
	Additional Extensions
	Adding an Extension
	Modifying an Extension
	Deleting Extensions


	Advanced Settings
	Default Keys Settings
	Error Handling
	Other Settings



